Topic: A resolution inconvenience

  • Author
  • #5230
    Avatar photoTrig

    I have my laptop plugged into a monitor, where I run the game at 1920×1080 resolution.

    Then I went for a trip and tried to launch the game just on the laptop’s 1360×768 monitor and while it loaded up fine the start menu was still expecting the older resolution, which meant all the buttons, including the one with options, to change the resolution was outside of the screen, so I couldn’t change it. Basically I’d have to remove and re-downlaod the game to reset the resolution and play the game.

    Possible solutions:

    1. Have the game recognise max resolution on any given monitor and adapt automatically.
    2. Put a settings.exe in the game folder so when needed, can be clicked and set up outside of the game.
    3. Put a settings.cfg text file in the game folder so a desired resolution could be typed in there if needed and game should read that file.
    4. Move the buttons in start menu to the center of the screen, so they’re visible at any resolution and can be accessed and clicked.

    Avatar photoRap

    For the time being you can delete the file C:\ProgramData\Overhype Studios\Battle Brothers\config.cfg to reset the game options without having to do any removing or re-downloading.

    Overhype Studios - follow us!
    Facebook Youtube

    Avatar photoTrig

    Ah there it is, thanks. I was looking for it in the Steam game folder.

    Avatar photodrpossible

    This is still a problem today, five years later, in 2020. I had to hunt for the correct config.cfg file — I found several, and had to delete them all simultaneously. Apparently my Documents folder is in the OneDrive Cloud and the GOG Cloud and one or both of those services kept rewriting and replacing the deleted file with the broken version. Here’s where I found mine:

    C:\Users\alex\Documents\Battle Brothers

    C:\Users\alex\OneDrive\Documents\Battle Brothers

    I note also that these are different locations on my disk and some games files (log.html and version.cfg) seem to be written in one and others (savegames) seem to be written in the other — or both? This is buggy code and I wish you’d either fix it, or open-source it so the community can fix it ourselves.

    Update: to unify the directories, I had to delete one, and link the other, like this (from console as administrator):

    cd C:\Users\alex\Documents
    mklink /J "Battle Brothers" "C:\Users\alex\OneDrive\Documents\Battle Brothers"
    Junction created for Battle Brothers <<===>> C:\Users\alex\OneDrive\Documents\Battle Brothers
Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.