Reply To: Failed to create OpenGL 3.3 context

#16734
Rap
Keymaster

Unfortunately I’m not familiar with vmware. Even if it does support OpenGL 3.3, does your video card, too? Your DxDiag.txt only reports some virtual vmware device, so I’m unable to see what video card you actually have. If you haven’t done so already, I suggest you make sure that your video drivers (on your actual OS, outside of vmware) are up-to-date.

There’s another thing you can try;

* Right-click on Battle Brothers in your Steam library
* Select ‘Properties’
* Select ‘Set Launch Options’
* Enter ‘-gl30’

This will force the game to run on OpenGL 3.1, but your video card is still required to support several extensions that are part of the OpenGL 3.3 specifications.

Overhype Studios - follow us!
Facebook Youtube
Twitter