Reply To: I'm not sure whether this is your problem.

#18002
Love Gun
Participant

Do you have Steam Cloud synchronisation enabled for Battle Brothers?

My guess would be that that’s the problem.
Give disabling that feature a try.

In case you don’t know how:
Right-click on the entry of Battle Brothers in the Steam library > Properties > Updates > uncheck the box at “Enable Steam Cloud synchronisation for Battle Brothers”

After you have disabled it, started the game, maybe loaded and saved your savegames, closed the game again, it should be possible to re-enable Steam Cloud without experiencing any problems anymore.