Reply To: Extreme Input Lag

Avatar photoJohnKlein94

I just bought this game, and tried it out from Steam as well as GOG, and I’m getting extreme input lag anywhere in the game. I searched through some old threads from here, Steam, and reddit, and none of the solutions appeared to work.

What’s happening is that when I start up the game, my mouse moves extremely slow, as if I’m trying to play this on a 1990 Tandy. I can enable hardware cursor which fixes how fast the mouse moves, but it doesn’t fix how fast the game realizes my mouse is on the element. Friends advised me to find out more information at, so I asked for help. Perhaps the problem with the VPN and need to choose another option. Here’s everything I’ve tried:

– Run the executable as Administrator (under ${INSTALL_DIR}\win32\BattleBrothers.exe
– Update the compatibility settings directly on the .exe and:
– Run in compatibility mode for Win 7
– Run in compatibility mode for Win X SP3
– Unchecked “Override high DPI scaling behavior
– Re-checked it, but set “Scaling performed by” to “System”
– Reinstalled game after uninstalling and also deleting the folder under “${HOME}\My Documents\Battle Brothers”
– Reinstalled game on a completely different physical drive

All other games continue to work fine, which include Mechwarrior 5, Metro Exodus, Baldur’s Gate 3, and a couple others.

Anyone have any suggestions on what else I might try?


Below are system specs:

Processor AMD Ryzen 7 3700X 8-Core Processor 3.60 GHz
Installed RAM 64.0 GB
System type 64-bit operating system, x64-based processor
Edition Windows 10 Home
Version 21H2
Installed on ‎3/‎14/‎2021
OS build 19044.1889
Experience Windows Feature Experience Pack 120.2212.4180.0

I had never heard of such a problem before, I even wondered.