Reply To: Why Combat Demo requires service pack 3?

#685
Rap
Keymaster

I’ve tried to launch BattleBrothers-CombatDemo-Setup.exe on windows XP with SP1. Is there any possibility?

No, I’m afraid not. But as Dohon said, it’d be a good idea to upgrade to SP3 anyway.

Overhype Studios - follow us!
Facebook Youtube
Twitter