Topic: 90% of Combat Sounds Don’t Play

  • Author
    Posts
  • #18327
    Ned_52
    Participant

    I know this was a problem back in March for some people but I’m having it now, it has happened every battle across 3 different campaigns. I verified integrity of the cache after the first campaign with this issue, continued to have it in the second campaign and decided to just reinstall completely which hasn’t made a difference even slightly. It happens every battle regardless of what happens beforehand and I know it isn’t my sound setting playing up since occasionally I’ll still get the sound of an attack.

    #18334
    Ned_52
    Participant

    Oh sorry, forgot to put my log in a .rar

    Attachments:
    #18542
    Ned_52
    Participant

    Bump? This is still occurring and no one on here or on the steam forum has said anything.

    #18543
    Rahziel
    Participant

    Try to update any drivers you can, and if it’s hardware issue – did you have similar issues in another games/programs?

    You might want to add a more extensive info like DxDiag report, for example, to make it easier to narrow down the source of this problem.
    What about your windows sound settings? (it can Mute all sounds if detecting communication activity)
    What programs running in background while you play Battle Brothers?
    Can you recall any changes preceding this problem, like (un)installing new software, changing or updating something?
    Since when did this problem began appearing for you (new patch/update)? Did you play on this same version without experiencing this problem?

    #18559
    Ned_52
    Participant

    All of my drivers are up to date, and the game is not muted, I still get ambient sounds such as birds chirping and sounds of movement as well as the occasional kachunk or miss sound it’s just that those sounds that play when attacks are made do not play 90% of the time, there is no swinging sound, no woosh or grunt when the attack lands just the usual sounds as if nothing is happening. It isn’t a hardware issue as every other game I play is fine with perfect sound quality, including Battle Brothers it’s almost as if the sound files for the attacks are no longer there or at least not playing.

    I have done multiple fresh installs and verified the integrity of the cache on steam 5 times, never once has steam told me a file was missing. Launching from a desktop shortcut or directly from the steam apps folder does not change anything and the problems continue to persist. I have tried multiple times to launch the game with nothing else except for steam open and even if I did have other programs open it is not as if the other sounds are messing up or playing quietly or out of sync since every other sound EXCEPT for hit and miss sounds plays when it should in perfect volume and quality.

    I have not played the game for several updates and decided to get back into it recently only for this issue to occur, I haven’t played since a few months after the map overhaul but had no issues relating to this at any point in my 70 hours of gameplay. This problem isn’t occurring across a single campaign I have tried new ones multiple times just for this issue to occur in both the tutorial and all fights after this.

    Attachments:
    #18562
    Rahziel
    Participant

    In Win10 Build 14393 insider preview (this one?) there are alot of problems with sound (Realtek included) and many suggestions how to try and fix it or make a workaround.
    If these doesn’t help, try to search for one which would work for you. If all else fails let’s wait for Dev’s response.

    Some advices suggest: “Open Playback Devices, right click the audio output device and set it as the default device. With this done, select it, hit Properties, move to the Enhancements tab and check the Disable all enhancements option.”
    Another say: “Go to Advanced section and change the bit rate to 24bit/44100 Hz”

    There’re a lot more: Google: RTKVHD64.sys win10, form which several tips

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.