Topic: How to Report Bugs

  • Author
    Posts
  • #24094
    Toborthe8thman
    Participant

    I’m new to the game. When I’ve met brigand raiders st a town and I try to enter the town. The screen freezes at a splash page and never loads for combat nor appear in the town I’ve selected. This happened when there were 1 and 2 brigand raiders present. I one time waited for 30 minutes but no ther screen loaded.

    #24418
    soupidity
    Participant

    I’m fighting some zombie monkeys on a steppe tileset; I hear rain falling but see no rain falling.

    All the stuff attached,
    cheers.

    p.s. Give us snowy mountains to (not want to but sometimes be forced to) fight in!
    p.p.s. Posting here because issue not worth cluttering with a new thread

    https://www.mediafire.com/file/b5e3uzyj1fk0yob/log.html/file

    Attachments:
    You must be logged in to view attached files.
    #18690
    Tucker
    Participant

    1. Describe the bug and how it happened: What did you do before and while it appeared?
    I’ve got a recurring crash bug that happens about twice an hour. Occasionally when I mouse over something I get an error message with a file path to the tool-tip of the thing I moused over and a recommendation to update my graphics drivers if this happens repeatedly at game start (which I have and it doesn’t), then the game crashes. This also seems to sometimes happen when I open the character menu. It seems to happen at random times.

    2. Is it reproducible? Can you intentionally make it appear?
    Not reliably, but it seems to happen more when I mouse over things and open and close menus.

    3. Attach a screenshot if possible.
    This being a unreliable crash bug makes that tricky. It’s just a black screen with an error message anyway.

    Requested files are attached.

    Attachments:
    You must be logged in to view attached files.
    #25008
    PhilThePizzaGuy
    Participant

    1. Describe the bug and how it happened: What did you do before and while it appeared?
    I have talked about this bug earlier but my visual bug has reappeared. Large pixels of random colors are replacing pieces of land/objects during battles. The bug only seems to appear once I reach late game scenarios. I have deleted all of the files (from steam/common) and have reinstalled the game but that hasn’t helped. I quit the game once because of this but I’d really like to make it work.

    2. Is it reproducable? Can you intentionally make it appear?
    It just randomly appears around day 160-200.

    3. Attach a screenshot if possible.
    Last Goblin battle.

    4,5,6:
    I have already tried to delete all of the files and redownload the game. When I started up the game again, I see my old save files. I know about the steamapp/common folder but where else can I look to remove everything?

    Attachments:
    You must be logged in to view attached files.
    #25012
    RapRap
    Keymaster

    Follow the instructions here and remove any mods.

    Overhype Studios - follow us!
    Facebook Youtube
    Twitter

    #25381
    PhilThePizzaGuy
    Participant

    1. Describe the bug and how it happened: What did you do before and while it appear?
    When i loaded my save file my monitor disconnects. i have to press the home button to bring screen back. It continues when I get into a battle. anytime I engage in battle the screen goes blank and says “Connection Lost”. This only happens with this game.

    2. Is it reproducable? Can you intentionally make it appear?
    I can reproduce this by simply loading a save file or getting into a battle. Even when I start a new game it happens during loading screen.

    3. Attach a screenshot if possible.
    I can’t screenshot a lost connection to my monitor (what I see isn’t what would be screenshot).

    4. Attach your dx.diag. This file includes information on your hard- and software configuration.

    5. Attach the Battle Brothers “log.html” file. (Please note the log gets overwritten once you restart the game so make sure you copy the log right after the bug appeared!)
    It’s not letting me add multiple files so I will post this separately.

    6. Attach a save showing the issue, if there is any.
    It’s not letting me add multiple files so I will post this separately.

    #25382
    PhilThePizzaGuy
    Participant

    Nevermind, I can attach files but they won’t send.

    #25383
    Zmey
    Participant

    A critical error occurred when I returned to a town, from a quest to find some location (I also destroyed it, although it wasn’t part of the quest).
    Critical message in an attachment.

    Log:

    19:31:02
    SQ
    contract added: Hunting Giants
    19:31:05
    SQ
    contract added: Defend settlement
    19:31:06
    SQ
    contract removed: 564
    19:31:07
    SQ
    contract added: Defend settlement
    19:31:16
    Core
    A critical exception occured.
    19:31:16
    Core
    Modules & Application Stacktrace:
    SymInit: Symbol-SearchPath: ‘.;C:\games\steamapps\common\Battle Brothers;C:\games\steamapps\common\Battle Brothers\win32;C:\Windows;C:\Windows\system32;SRV*C:\websymbols*http://msdl.microsoft.com/download/symbols;’, symOptions: 530, UserName: ‘xxxxx’
    OS-Version: 6.1.7601 (Service Pack 1) 0x300-0x1
    19:31:16
    Core
    Script Stacktrace:
    Function:
    unknown -> NATIVE : -1
    Function:
    onPrepareVariables -> scripts/contracts/contracts/discover_location_contract.nut : 568
    Function:
    buildText -> scripts/contracts/contract.nut : 429
    Function:
    setScreen -> scripts/contracts/contract.nut : 326
    Function:
    update -> scripts/contracts/contracts/discover_location_contract.nut : 272
    Function:
    update -> scripts/contracts/contract.nut : 176
    Function:
    update -> scripts/contracts/contract_manager.nut : 94
    Function:
    onUpdate -> scripts/states/world_state.nut : 700

    Attachments:
    You must be logged in to view attached files.
    #25458
    vshekn
    Participant

    Exception happened during battle then I moved one of my battle brothers near the enemy

    Attachments:
    You must be logged in to view attached files.
    #25545
    Hagleboz
    Participant

    The save for my Ironman game is missing. I put my computer to sleep with BB running which I do often and when I woke it back up the save for my game is just gone. I’ve checked the documents folder and the Steam Cloud and the save file is not in either one. Game day was in high 90’s. I don’t know if I had saved and closed or still had the campaign running when I put the computer to sleep

    My game/company name was: Seven Days of Toil

    I restarted the game so I think my log (attached) is useless

    I’m really bummed. This is really the only game I play due to limited free time and have about 2 months into the campaign. Please let me know if there is anything else I can provide. Any help would be greatly appreciated.

    Attachments:
    You must be logged in to view attached files.
    #26769
    ichoglan
    Participant

    Hi,

    I’ve noticed that the min damage attack/lash dialog boxes for a named flail I purchased are wrong. In the attached screens, you can see that that the min damage is being 1/3’ed, even though the game says a further 1/3 will be applied to this value (the max damage looks correct). The math in the code may still be correct, but it does seem as though my duelist is occasionally doing exceptionally low damage with this weapon.

    I’ve also attached a save file, but not dx_dialog or log files since this obviously isn’t causing a game crash.

    Thanks, and can’t wait for the DLC!
    Ethan

    #26770
    ichoglan
    Participant

    Screens and saves all exceeded limit, so here’s a zip file for the previous topic

Viewing 12 posts - 31 through 42 (of 42 total)
  • You must be logged in to reply to this topic.